Windows PowerShell command on Get-command dupmsg
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man dupmsg

Kernel Functions for Drivers dupmsg(9F)

NAME

dupmsg - duplicate a message

SYNOPSIS

#include

mblk_t *dupmsg(mblk_t *mp);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

mp Pointer to the message.

DESCRIPTION

dupmsg() forms a new message by copying the message block

descriptors pointed to by mp and linking them. dupb(9F) is called for each message block. The data blocks themselves are not duplicated.

RETURN VALUES

If successful, dupmsg() returns a pointer to the new mes-

sage block. Otherwise, it returns a NULL pointer. A return value of NULL indicates either memory depletion or the data

block reference count, db_ref (see datab(9S)), has reached a

limit (255). See dupb(9F).

CONTEXT

dupmsg() can be called from user, kernel, or interrupt con-

text.

EXAMPLES

Example 1 Using dupmsg()

See copyb(9F) for an example using dupmsg().

SEE ALSO

copyb(9F), copymsg(9F), dupb(9F), datab(9S) Writing Device Drivers STREAMS Programming Guide

SunOS 5.11 Last change: 11 Apr 1991 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™