Windows PowerShell command on Get-command drv_usecwait
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man drv_usecwait

Kernel Functions for Drivers drv_usecwait(9F)

NAME

drv_usecwait - busy-wait for specified interval

SYNOPSIS

#include

#include

void drv_usecwait(clock_t microsecs);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

microsecs The number of microseconds to busy-wait.

DESCRIPTION

The drv_usecwait() function gives drivers a means of busy-

waiting for a specified microsecond count. The amount of

time spent busy-waiting may be greater than the microsecond

count but will minimally be the number of microseconds specified. delay(9F) can be used by a driver to delay for a specified number of system ticks, but it has two limitations. First, the granularity of the wait time is limited to one clock tick, which may be more time than is needed for the delay. Second, delay(9F) can be invoked from user or kernel context

and hence cannot be used at interrupt time or system ini-

tialization. Often, drivers need to delay for only a few microseconds, waiting for a write to a device register to be picked up by the device. In this case, even in user context, delay(9F) produces too long a wait period.

CONTEXT

The drv_usecwait() function can be called from user, inter-

rupt, or kernel context.

SEE ALSO

delay(9F), timeout(9F), untimeout(9F) Writing Device Drivers

SunOS 5.11 Last change: 16 Jan 2006 1

Kernel Functions for Drivers drv_usecwait(9F)

NOTES The driver wastes processor time by making this call since

drv_usecwait() does not block but simply busy-waits. The

driver should only make calls to drv_usecwait() as needed,

and only for as much time as needed. The drv_usecwait()

function does not mask out interrupts.

SunOS 5.11 Last change: 16 Jan 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™