Windows PowerShell command on Get-command drv_usectohz
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man drv_usectohz

Kernel Functions for Drivers drv_usectohz(9F)

NAME

drv_usectohz - convert microseconds to clock ticks

SYNOPSIS

#include

#include

clock_t drv_usectohz(clock_t microsecs);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

microsecs The number of microseconds to convert.

DESCRIPTION

The drv_usectohz() function converts a length of time

expressed in microseconds to a number of system clock ticks. The time arguments to timeout(9F) and delay(9F) are expressed in clock ticks.

The drv_usectohz() function is a portable interface for

drivers to make calls to timeout(9F) and delay(9F) and remain binary compatible should the driver object file be used on a system with a different clock speed (a different number of ticks in a second).

RETURN VALUES

The value returned is the number of system clock ticks equivalent to the microsecs argument. No error value is returned. If the clock tick equivalent to microsecs is too

large to be represented as a clock_t, then the maximum

clock_t value will be returned.

CONTEXT

The drv_usectohz() function can be called from user, inter-

rupt, or kernel context.

SEE ALSO

delay(9F), drv_hztousec(9F), timeout(9F)

Writing Device Drivers NOTES

If the microsecs argument to drv_usectohz() is less than

drv_hztousec(9F), drv_usectohz() returns one tick. This,

SunOS 5.11 Last change: 24 Apr 2008 1

Kernel Functions for Drivers drv_usectohz(9F)

coupled with multiplication, can result in significantly longer durations than expected. For example, on a machine

where hz is 100, calling drv_usectohz() with a microsecs

value less than 10000 returns a result equivalent to 10000 (1 tick). This type of mistake causes code such as"5000 *

drv_usectohz(1000)" to compute a duration of 50 seconds

instead of the intended 5 seconds.

SunOS 5.11 Last change: 24 Apr 2008 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™