Windows PowerShell command on Get-command drv_hztousec
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man drv_hztousec

Kernel Functions for Drivers drv_hztousec(9F)

NAME

drv_hztousec - convert clock ticks to microseconds

SYNOPSIS

#include

#include

clock_t drv_hztousec(clock_t hertz);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

hertz The number of clock ticks to convert.

DESCRIPTION

The drv_hztousec() function converts into microseconds the

time expressed by hertz, which is in system clock ticks. The length of time the system has been up since boot can be

retrieved by calling ddi_get_lbolt(9F), which will return a

value of type clock_t containing the number of clock ticks

since boot. Drivers often use the value of lbolt before and

after an I/O request to measure the amount of time it took

the device to process the request. The drv_hztousec() func-

tion can be used by the driver to convert the reading from clock ticks to a known unit of time.

RETURN VALUES

The number of microseconds equivalent to the hertz parame-

ter. No error value is returned. If the microsecond equivalent to hertz is too large to be represented as a

clock_t, then the maximum clock_t value will be returned.

CONTEXT

The drv_hztousec() function can be called from user, inter-

rupt, or kernel context.

SEE ALSO

ddi_get_lbolt(9F), drv_usectohz(9F), drv_usecwait(9F)

Writing Device Drivers

SunOS 5.11 Last change: 4 Sep 2009 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™