Kernel Functions for Drivers devmap_set_ctx_timeout(9F)
NAME
devmap_set_ctx_timeout - set the timeout value for the con-
text management callbackSYNOPSIS
#include
#include
void devmap_set_ctx_timeout(devmap_cookie_t dhp, clock_t ticks);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).PARAMETERS
dhp An opaque mapping handle that the system uses to describe the mapping. ticks Number of clock ticks to wait between successive calls to the context management callback function.DESCRIPTION
The devmap_set_ctx_timeout() function specifies the time
interval for the system to wait between successive calls to the driver's context management callback function,devmap_contextmgt(9E).
Device drivers typically call devmap_set_ctx_timeout() in
the devmap_map(9E) routine. If the drivers do not call
devmap_set_ctx_timeout() to set the timeout value, the
default timeout value of 0 will result in no delay betweensuccessive calls to the driver's devmap_contextmgt(9E) call-
back function.CONTEXT
The devmap_set_ctx_timeout() function can be called from
user, interrupt, or kernel context.SEE ALSO
devmap_contextmgt(9E), devmap_map(9E), timeout(9F)
SunOS 5.11 Last change: 16 Jan 2006 1