Kernel Functions for Drivers ddi_get_driver_private(9F)
NAME
ddi_get_driver_private, ddi_set_driver_private - get or set
the address of the device's private data areaSYNOPSIS
#include
#include
#include
void ddi_set_driver_private(dev_info_t *dip, void *data);
void *ddi_get_driver_private(dev_info_t *dip);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).PARAMETERS
ddi_get_driver_private()
dip Pointer to device information structure to get from.ddi_set_driver_private()
dip Pointer to device information structure to set. data Data area address to set.DESCRIPTION
The ddi_get_driver_private() function returns the address of
the device's private data area from the device information structure pointed to by dip.The ddi_set_driver_private() function sets the address of
the device's private data area in the device information structure pointed to by dip with the value of data.RETURN VALUES
The ddi_get_driver_private() function returns the contents
of devi_driver_data. If ddi_set_driver_private() has not
been previously called with dip, an unpredictable value is returned.SunOS 5.11 Last change: 16 Jan 2006 1
Kernel Functions for Drivers ddi_get_driver_private(9F)
CONTEXT
These functions can be called from user , interrupt, or ker-
nel context.SEE ALSO
Writing Device DriversSunOS 5.11 Last change: 16 Jan 2006 2