Kernel Functions for Drivers ddi_rep_put8(9F)
NAME
ddi_rep_put8, ddi_rep_put16, ddi_rep_put32, ddi_rep_put64,
ddi_rep_putb, ddi_rep_putw, ddi_rep_putl, ddi_rep_putll -
write data to the mapped memory address, device register or allocated DMA memory addressSYNOPSIS
#include
#include
void ddi_rep_put8(ddi_acc_handle_t handle, uint8_t *host_addr,
uint8_t *dev_addr, size_t repcount, uint_t flags);
void ddi_rep_put16(ddi_acc_handle_t handle, uint16_t *host_addr,
uint16_t *dev_addr, size_t repcount, uint_t flags);
void ddi_rep_put32(ddi_acc_handle_t handle, uint32_t *host_addr,
uint32_t *dev_addr, size_t repcount, uint_t flags);
void ddi_rep_put64(ddi_acc_handle_t handle, uint64_t *host_addr,
uint64_t *dev_addr,size_t repcount, uint_t flags);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). The ddi_rep_putb(),
ddi_rep_putl(), ddi_rep_putll(), and ddi_rep_putw() func-
tions are obsolete. The ddi_rep_put8() function replaces
ddi_rep_putb(). The ddi_rep_put32() function replaces
ddi_rep_putl(). The ddi_rep_put64() function replaces
ddi_rep_putll(). The ddi_rep_put16() function replaces
ddi_rep_putw().
PARAMETERS
handle The data access handle returned from setupcalls, such as ddi_regs_map_setup(9F).
host_addr Base host address.
dev_addr Base device address.
repcount Number of data accesses to perform.SunOS 5.11 Last change: 1 Nov 2005 1
Kernel Functions for Drivers ddi_rep_put8(9F)
flags Device address flags:DDI_DEV_AUTOINCR Automatically increment
the device address,dev_addr, during data
accesses.DDI_DEV_NO_AUTOINCR Do not advance the dev-
ice address, dev_addr,
during data accesses.DESCRIPTION
These routines generate multiple writes to the mapped memory or device register. repcount data is copied from the hostaddress, host_addr, to the device address, dev_addr. For
each input datum, the ddi_rep_put8(), ddi_rep_put16(),
ddi_rep_put32(), and ddi_rep_put64() functions write 8 bits,
16 bits, 32 bits, and 64 bits of data, respectively, to thedevice address, dev_addr. dev_addr and host_addr must be
aligned to the datum boundary described by the function. Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle.The translation may involve byte-swapping if the host and
the device have incompatible endian characteristics.When the flags argument is set to DDI_DEV_AUTOINCR, these
functions treat the device address, dev_addr, as a memory
buffer location on the device and increment its address on the next input datum. However, when the flags argument isset to DDI_DEV_NO_AUTOINCR, the same device address will be
used for every datum access. For example, this flag may be useful when writing to a data register.CONTEXT
These functions can be called from user, kernel, or inter-
rupt context.ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:SunOS 5.11 Last change: 1 Nov 2005 2
Kernel Functions for Drivers ddi_rep_put8(9F)
____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
| ____________________________|_____________________________|_
| Interface Stability | ddi_rep_putb(), |
| | ddi_rep_putl(), |
| | ddi_rep_putll(), and|
| | ddi_rep_putw() are Obsolete|
| | ddi_rep_put8(), |
| | ddi_rep_put16(), |
| | ddi_rep_put32(), |
| | ddi_rep_put64() are Commit-|
| | ted ||_____________________________|_____________________________|
SEE ALSO
ddi_get8(9F), ddi_put8(9F), ddi_regs_map_free(9F),
ddi_regs_map_setup(9F), ddi_rep_get8(9F),
ddi_device_acc_attr(9S)
SunOS 5.11 Last change: 1 Nov 2005 3