Kernel Functions for Drivers ddi_remove_minor_node(9F)
NAME
ddi_remove_minor_node - remove a minor node for this
dev_info
SYNOPSIS
void ddi_remove_minor_node(dev_info_t *dip, char *name);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).PARAMETERS
dip A pointer to the device's dev_info structure.
name The name of this minor device. If name is NULL, then remove all minor data structures from thisdev_info.
DESCRIPTION
ddi_remove_minor_node() removes a data structure from the
linked list of minor data structures that is pointed to bythe dev_info structure for this driver.
EXAMPLES
Example 1 Removing a minor node This will remove a data structure describing a minor devicecalled dev1 which is linked into the dev_info structure
pointed to by dip:ddi_remove_minor_node(dip, "dev1");
SEE ALSO
attach(9E), detach(9E), ddi_create_minor_node(9F)
Writing Device DriversSunOS 5.11 Last change: 10 Mar 1992 1