Windows PowerShell command on Get-command ddi_mem_rep_putb
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_mem_rep_putb

Kernel Functions for Drivers ddi_mem_rep_put8(9F)

NAME

ddi_mem_rep_put8, ddi_mem_rep_put16, ddi_mem_rep_put32,

ddi_mem_rep_put64, ddi_mem_rep_putb, ddi_mem_rep_putl,

ddi_mem_rep_putll, ddi_mem_rep_putw - write multiple data to

mapped device in the memory space or allocated DMA memory

SYNOPSIS

#include

#include

void ddi_mem_rep_put8(ddi_acc_handle_t handle, uint8_t *host_addr,

uint8_t *dev_addr, size_t repcount, uint_t flags);

void ddi_mem_rep_put16(ddi_acc_handle_t handle, uint16_t *host_addr,

uint16_t *dev_addr, size_t repcount, uint_t flags);

void ddi_mem_rep_put32(ddi_acc_handle_t handle, uint32_t *host_addr,

uint32_t *dev_addr, size_t repcount, uint_t flags);

void ddi_mem_rep_put64(ddi_acc_handle_t handle, uint64_t *host_addr,

uint64_t *dev_addr, size_t repcount, uint_t flags);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI). The ddi_mem_rep_put8(),

ddi_mem_rep_put16(), ddi_mem_rep_put32(),

ddi_mem_rep_put64(), ddi_mem_rep_putb(), ddi_mem_rep_putl(),

ddi_mem_rep_putll(), and ddi_mem_rep_putw() functions are

obsolete. The ddi_rep_put8(9F) function replaces

ddi_mem_rep_put8(). The ddi_rep_put16(9F) function replaces

ddi_mem_rep_put16(). The ddi_rep_put32(9F) function replaces

ddi_mem_rep_put32(). The ddi_rep_put64(9F) function replaces

ddi_mem_rep_put64(). The ddi_rep_put8(9F) function replaces

ddi_mem_rep_putb(). The ddi_rep_put32(9F) function replaces

ddi_mem_rep_putl(). The ddi_rep_put64(9F) function replaces

ddi_mem_rep_putll(). The ddi_rep_put16(9F) function replaces

ddi_mem_rep_putw().

PARAMETERS

handle The data access handle returned from setup

calls, such as ddi_regs_map_setup(9F).

host_addr Base host address.

SunOS 5.11 Last change: 1 Nov 2005 1

Kernel Functions for Drivers ddi_mem_rep_put8(9F)

dev_addr Base device address.

repcount Number of data accesses to perform. flags Device address flags:

DDI_DEV_AUTOINCR Automatically increment

the device address,

dev_addr, during data

accesses.

DDI_DEV_NO_AUTOINCR Do not advance the dev-

ice address, dev_addr,

during data accesses.

DESCRIPTION

These routines generate multiple writes to memory space or allocated DMA memory. repcount data is copied from the host

address, host_addr, to the device address, dev_addr, in

memory space. For each input datum, the ddi_mem_rep_put8(),

ddi_mem_rep_put16(), ddi_mem_rep_put32(), and

ddi_mem_rep_put64() functions write 8 bits, 16 bits, 32 bits

and 64 bits of data, respectively, to the device address.

dev_addr and host_addr must be aligned to the datum boundary

described by the function. Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle.

The translation may involve byte-swapping if the host and

the device have incompatible endian characteristics.

When the flags argument is set to DDI_DEV_AUTOINCR, these

functions will treat the device address, dev_addr, as a

memory buffer location on the device and increments its address on the next input datum. However, when the flags

argument is set to DDI_DEV_NO_AUTOINCR, the same device

address will be used for every datum access. For example, this flag may be useful when writing from a data register.

CONTEXT

These functions can be called from user, kernel, or inter-

rupt context.

SunOS 5.11 Last change: 1 Nov 2005 2

Kernel Functions for Drivers ddi_mem_rep_put8(9F)

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Obsolete |

|_____________________________|_____________________________|

SEE ALSO

ddi_mem_get8(9F), ddi_mem_put8(9F), ddi_mem_rep_get8(9F),

ddi_regs_map_setup(9F), ddi_rep_put8(9F), ddi_rep_put16(9F),

ddi_rep_put32(9F), ddi_rep_put64(9F),

ddi_device_acc_attr(9S)

SunOS 5.11 Last change: 1 Nov 2005 3




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™