Kernel Functions for Drivers ddi_io_rep_put8(9F)
NAME
ddi_io_rep_put8, ddi_io_rep_put16, ddi_io_rep_put32,
ddi_io_rep_putb, ddi_io_rep_putl, ddi_io_rep_putw - write
multiple data to the mapped device register in I/O space
SYNOPSIS
#include
#include
void ddi_io_rep_put8(ddi_acc_handle_t handle, uint8_t *host_addr,
uin8_t *dev_addr, size_t repcount);
void ddi_io_rep_put16(ddi_acc_handle_t handle, uint16_t *host_addr,
uin16_t *dev_addr, size_t repcount);
void ddi_io_rep_put32(ddi_acc_handle_t handle, uint32_t *host_addr,
uin32_t *dev_addr, size_t repcount);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). The ddi_io_rep_put8(),
ddi_io_rep_put16(), ddi_io_rep_put32(), ddi_io_rep_putb(),
ddi_io_rep_putl(), and ddi_io_rep_putw() functions are
obsolete. The ddi_rep_put8(9F) function replaces
ddi_io_rep_put8(). The ddi_rep_put16(9F) function replaces
ddi_io_rep_put16(). The ddi_rep_put32(9F) function replaces
ddi_io_rep_put32(). The ddi_rep_put8(9F) function replaces
ddi_io_rep_putb(). The ddi_rep_put32(9F) function replaces
ddi_io_rep_putl(). The ddi_rep_put16(9F) function replaces
ddi_io_rep_putw().
PARAMETERS
handle Data access handle returned from setup calls,such as ddi_regs_map_setup(9F).
host_addr Base host address.
dev_addr Base device address.
repcount Number of data accesses to perform.DESCRIPTION
These routines generate multiple writes to the deviceaddress, dev_address, in I/O space. repcount data is copied
SunOS 5.11 Last change: 1 Nov 2005 1
Kernel Functions for Drivers ddi_io_rep_put8(9F)
from the host address, host_addr, to the device address,
dev_addr. For each input datum, the ddi_io_rep_put8(),
ddi_io_rep_put16(), and ddi_io_rep_put32() functions write 8
bits, 16 bits, and 32 bits of data, respectively, to thedevice address. host_addr must be aligned to the datum boun-
dary described by the function. Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle.The translation may involve byte-swapping if the host and
the device have incompatible endian characteristics.CONTEXT
These functions can be called from user, kernel, or inter-
rupt context.ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Interface Stability | Obsolete ||_____________________________|_____________________________|
SEE ALSO
isa(4), ddi_io_get8(9F), ddi_io_put8(9F),
ddi_io_rep_get8(9F), ddi_regs_map_setup(9F),
ddi_rep_put8(9F), ddi_rep_put16(9F), ddi_rep_put32(9F),
ddi_device_acc_attr(9S)
SunOS 5.11 Last change: 1 Nov 2005 2