Windows PowerShell command on Get-command ddi_io_get8
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_io_get8

Kernel Functions for Drivers ddi_io_get8(9F)

NAME

ddi_io_get8, ddi_io_get16, ddi_io_get32, ddi_io_getb,

ddi_io_getl, ddi_io_getw - read data from the mapped device

register in I/O space

SYNOPSIS

#include

#include

uint8_t ddi_io_get8(ddi_acc_handle_t handle, uint8_t *dev_addr);

uint16_t ddi_io_get16(ddi_acc_handle_t handle, uint16_t *dev_addr);

uint32_t ddi_io_get32(ddi_acc_handle_t handle, uint32_t *dev_addr);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI). The ddi_io_get8(),

ddi_io_get16(), ddi_io_get32(), ddi_io_getb(),

ddi_io_getl(), and ddi_io_getw() functions are obsolete. The

ddi_get8(9F) function replaces ddi_io_get8(). The

ddi_get16(9F) function replaces ddi_io_get16(). The

ddi_get32(9F) function replaces ddi_io_get32(). The

ddi_get8(9F) function replaces ddi_io_getb(). The

ddi_get32(9F) function replaces ddi_io_getl(). The

ddi_get16(9F) function replaces ddi_io_getw().

PARAMETERS

handle Data access handle returned from setup calls,

such as ddi_regs_map_setup(9F).

dev_addr Device address.

DESCRIPTION

These routines generate a read of various sizes from the

device address, dev_addr, in I/O space. The ddi_io_get8(),

ddi_io_get16(), and ddi_io_get32() functions read 8 bits, 16

bits, and 32 bits of data, respectively, from the device

address, dev_addr.

Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle.

The translation may involve byte-swapping if the host and

the device have incompatible endian characteristics.

SunOS 5.11 Last change: 1 Nov 2005 1

Kernel Functions for Drivers ddi_io_get8(9F)

CONTEXT

These functions can be called from user, kernel, or inter-

rupt context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Obsolete |

|_____________________________|_____________________________|

SEE ALSO

isa(4), ddi_get8(9F), ddi_get16(9F), ddi_get32(9F),

ddi_io_put8(9F), ddi_io_rep_get8(9F), ddi_io_rep_put8(9F),

ddi_regs_map_free(9F), ddi_regs_map_setup(9F),

ddi_device_acc_attr(9S)

SunOS 5.11 Last change: 1 Nov 2005 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™