Windows PowerShell command on Get-command ddi_intr_get_hilevel_pri
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_intr_get_hilevel_pri

Kernel Functions for Drivers ddi_intr_get_hilevel_pri(9F)

NAME

ddi_intr_get_hilevel_pri - get minimum priority level for a

high-level interrupt

SYNOPSIS

#include

#include

#include

#include

int ddi_intr_get_hilevel_pri(void);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

DESCRIPTION

Upon a successful return, the ddi_intr_get_hilevel_pri()

function returns the minimum priority level for a high-level

interrupt. The return priority value can be used to compare to other priority values, such as those returned from

ddi_intr_get_pri(9F), to determine if a given interrupt

priority is a high-level interrupt.

High-level interrupts must be handled without using system

services that manipulate thread or process states, because such interrupts are not blocked by the scheduler.

In addition, high-level interrupt handlers must take care to

do a minimum of work because they cannot be preempted.

A typical high-level interrupt handler puts data into a cir-

cular buffer and schedule a soft interrupt by calling

ddi_intr_trigger_softint(). The circular buffer can be pro-

tected by using a mutex that is properly initialized for the interrupt handler.

The ddi_intr_get_hilevel_pri() function can be used before

calling ddi_intr_add_handler() to help determine which type

of interrupt handler can be used. Most device drivers are designed with the knowledge that supported devices always generate low level interrupts. On some machines, however,

interrupts are high-level above the scheduler level and on

other machines they are not. Devices such as those those using SBus interrupts or VME bus level 6 or 7 interrupts

must use the ddi_intr_get_hilevel_pri() function to test the

type of interrupt handler that can be used.

SunOS 5.11 Last change: 07 Apr 2005 1

Kernel Functions for Drivers ddi_intr_get_hilevel_pri(9F)

RETURN VALUES

The ddi_intr_get_hilevel_pri() function returns the priority

value for a high-level interrupt.

CONTEXT

The ddi_intr_get_hilevel_pri() function can be called from

either user or kernel non-interrupt context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), ddi_intr_add_handler(9F), ddi_intr_alloc(9F),

ddi_intr_enable(9F), ddi_intr_get_pri(9F),

ddi_intr_trigger_softint(9F), mutex(9F)

Writing Device Drivers

SunOS 5.11 Last change: 07 Apr 2005 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™