Kernel Functions for Drivers ddi_in_panic(9F)
NAME
ddi_in_panic - determine if system is in panic state
SYNOPSIS
#include
#include
int ddi_in_panic(void);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).DESCRIPTION
Drivers controlling devices on which the system may write a kernel crash dump in the event of a panic can callddi_in_panic() to determine if the system is panicking.
When the system is panicking, the calls of functionsscheduled by timeout(9F) and ddi_trigger_softintr(9F) will
never occur. Neither can delay(9F) be relied upon, since it is implemented via timeout(9F). Drivers that need to enforce a time delay such as SCSI busreset delay time must busy-wait when the system is panick-
ing.RETURN VALUES
ddi_in_panic() returns 1 if the system is in panic, or 0
otherwise.CONTEXT
ddi_in_panic() may be called from any context.
SEE ALSO
dump(9E), delay(9F), ddi_trigger_softintr(9F), timeout(9F)
Writing Device DriversSunOS 5.11 Last change: 23 Jun 1997 1