Windows PowerShell command on Get-command ddi_get_lbolt64
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_get_lbolt64

Kernel Functions for Drivers ddi_get_lbolt(9F)

NAME

ddi_get_lbolt, ddi_get_lbolt64 - return the number of clock

ticks since boot

SYNOPSIS

#include

#include

#include

clock_t ddi_get_lbolt(void);

int64_t ddi_get_lbolt64(void);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

DESCRIPTION

The ddi_get_lbolt() function returns a value that represents

the number of clock ticks since the system booted. This

value is used as a counter or timer inside the system ker-

nel. The tick frequency can be determined by using

drv_usectohz(9F), which converts microseconds into clock

ticks.

The ddi_get_lbolt64() behaves essentially the same as

ddi_get_lbolt(), except the value is returned in a longer

data type (int64_t) that will not wrap for 2.9 billion

years.

RETURN VALUES

The ddi_get_lbolt() function returns the number of clock

ticks since boot in a clock_t type.

The ddi_get_lbolt64() function returns the number of clock

ticks since boot in a int64_t type.

CONTEXT

These routines can be called from any context.

SEE ALSO

ddi_get_time(9F), drv_getparm(9F), drv_usectohz(9F)

Writing Device Drivers STREAMS Programming Guide

SunOS 5.11 Last change: 4 Sep 2009 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™