Kernel Functions for Drivers ddi_get8(9F)
NAME
ddi_get8, ddi_get16, ddi_get32, ddi_get64, ddi_getb,
ddi_getw, ddi_getl, ddi_getll - read data from the mapped
memory address, device register or allocated DMA memory addressSYNOPSIS
#include
#include
uint8_t ddi_get8(ddi_acc_handle_t handle, uint8_t *dev_addr);
uint16_t ddi_get16(ddi_acc_handle_t handle, uint16_t *dev_addr);
uint32_t ddi_get32(ddi_acc_handle_t handle, uint32_t *dev_addr);
uint64_t ddi_get64(ddi_acc_handle_t handle, uint64_t *dev_addr);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). The ddi_getb(),
ddi_getl(), ddi_getll(), and ddi_getw() functions are
obsolete. The ddi_get8() function replaces ddi_getb(). The
ddi_get32() function replaces ddi_getl(). The ddi_get64()
function replaces ddi_getll(). The ddi_get16() function
replaces ddi_getw().
PARAMETERS
handle The data access handle returned from setupcalls, such as ddi_regs_map_setup(9F).
dev_addr Base device address.
DESCRIPTION
The ddi_get8(), ddi_get16(), ddi_get32(), and ddi_get64()
functions read 8 bits, 16 bits, 32 bits and 64 bits of data,respectively, from the device address, dev_addr.
Each individual datum will automatically be translated to maintain a consistent view between the host and the device based on the encoded information in the data access handle.The translation may involve byte-swapping if the host and
the device have incompatible endian characteristics.SunOS 5.11 Last change: 1 Nov 2005 1
Kernel Functions for Drivers ddi_get8(9F)
For certain bus types, you can call these DDI functions froma high-interrupt context. These types include ISA and SBus
buses. See sysbus(4), isa(4), and sbus(4) for details. For the PCI bus, you can, under certain conditions, call theseDDI functions from a high-interrupt context. See pci(4).
RETURN VALUES
These functions return the value read from the mapped address.CONTEXT
These functions can be called from user, kernel, or inter-
rupt context.ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
| ____________________________|_____________________________|_
| Interface Stability | ddi_getb(), ddi_getl(),|
| | ddi_getll(), and ddi_getw()|
| | are Obsolete; ddi_get8(),|
| | ddi_get16(), ddi_get32(),|
| | ddi_get64() are Committed |
|_____________________________|_____________________________|
SEE ALSO
ddi_put8(9F), ddi_regs_map_free(9F), ddi_regs_map_setup(9F),
ddi_rep_get8(9F), ddi_rep_put8(9F)
SunOS 5.11 Last change: 1 Nov 2005 2