Kernel Functions for Drivers ddi_ffs(9F)
NAME
ddi_ffs, ddi_fls - find first (last) bit set in a long
integerSYNOPSIS
#include
#include
#include
intddi_ffs(long mask);
int ddi_fls(long mask);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).PARAMETERS
mask A 32-bit argument value to search through.
DESCRIPTION
The function ddi_ffs() takes its argument and returns the
shift count that the first (least significant) bit set inthe argument corresponds to. The function ddi_fls() does the
same, only it returns the shift count for the last (most significant) bit set in the argument.RETURN VALUES
0 No bits are set in mask.N Bit N is the least significant (ddi_ffs) or most sig-
nificant (ddi_fls) bit set in mask. Bits are numbered
from 1 to 32, with bit 1 being the least significant bit position and bit 32 the most significant position.CONTEXT
This function can be called from user, interrupt, or kernel context.SEE ALSO
Writing Device DriversSunOS 5.11 Last change: 16 Jan 2006 1