Windows PowerShell command on Get-command ddi_dma_htoc
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_dma_htoc

Kernel Functions for Drivers ddi_dma_htoc(9F)

NAME

ddi_dma_htoc - convert a DMA handle to a DMA address cookie

SYNOPSIS

#include

#include

#include

int ddi_dma_htoc(ddi_dma_handle_t handle, off_t off,

ddi_dma_cookie_t *cookiep);

INTERFACE LEVEL

This interface is obsolete. ddi_dma_addr_bind_handle(9F) or

ddi_dma_buf_bind_handle(9F) should be used instead.

PARAMETERS

handle The handle filled in by a call to

ddi_dma_setup(9F).

off An offset into the object that handle maps.

cookiep A pointer to a ddi_dma_cookie(9S) structure.

DESCRIPTION

The ddi_dma_htoc() function takes a DMA handle (established

by ddi_dma_setup(9F)), and fills in the cookie pointed to by

cookiep with the appropriate address, length, and bus type to be used to program the DMA engine.

RETURN VALUES

The ddi_dma_htoc() function returns:

DDI_SUCCESS Successfully filled in the cookie pointed to

by cookiep.

DDI_FAILURE Failed to successfully fill in the cookie.

CONTEXT

The ddi_dma_htoc() function can be called from user, inter-

rupt, or kernel context.

ATTRIBUTES

See attributes(5) for a description of the following attri-

butes:

SunOS 5.11 Last change: 16 Jan 2006 1

Kernel Functions for Drivers ddi_dma_htoc(9F)

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Stability Level | Obsolete |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), ddi_dma_addr_bind_handle(9F),

ddi_dma_addr_setup(9F), ddi_dma_buf_bind_handle(9F),

ddi_dma_buf_setup(9F), ddi_dma_setup(9F), ddi_dma_sync(9F),

ddi_dma_cookie(9S)

Writing Device Drivers

SunOS 5.11 Last change: 16 Jan 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™