Windows PowerShell command on Get-command ddi_dma_get_attr
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_dma_get_attr

Kernel Functions for Drivers ddi_dma_get_attr(9F)

NAME

ddi_dma_get_attr - get the device DMA attribute structure

from a DMA handle

SYNOPSIS

#include

#include

int ddi_dma_get_attr(ddi_dma_handle_t handle, ddi_dma_attr_t *attrp);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI). This interface is obsolete.

PARAMETERS

handle The handle filled in by a call to

ddi_dma_alloc_handle(9F).

attrp Pointer to a buffer suitable for holding a DMA

attribute structure. See ddi_dma_attr(9S).

DESCRIPTION

ddi_dma_get_attr() is used to get a ddi_dma_attr(9S) struc-

ture. This structure describes the attributes of the DMA

data path to which any memory object bound to the given han-

dle will be subject.

RETURN VALUES

DDI_SUCCESS Successfully passed back attribute struc-

ture in buffer pointed to by attrp.

DDI_DMA_BADATTR A valid attribute structure could not be

passed back.

CONTEXT

ddi_dma_get_attr() can be called from any context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

SunOS 5.11 Last change: 12 Oct 2005 1

Kernel Functions for Drivers ddi_dma_get_attr(9F)

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Obsolete |

|_____________________________|_____________________________|

SEE ALSO

ddi_dma_alloc_handle(9F), ddi_dma_attr(9S)

SunOS 5.11 Last change: 12 Oct 2005 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™