Windows PowerShell command on Get-command ddi_dma_free_handle
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_dma_free_handle

Kernel Functions for Drivers ddi_dma_free_handle(9F)

NAME

ddi_dma_free_handle - free DMA handle

SYNOPSIS

#include

#include

void ddi_dma_free_handle(ddi_dma_handle_t *handle);

PARAMETERS

handle A pointer to the DMA handle previously allocated

by a call to ddi_dma_alloc_handle(9F).

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

DESCRIPTION

ddi_dma_free_handle() destroys the DMA handle pointed to by

handle. Any further references to the DMA handle will have

undefined results. Note that ddi_dma_unbind_handle(9F) must

be called prior to ddi_dma_free_handle() to free any

resources the system may be caching on the handle.

CONTEXT

ddi_dma_free_handle() can be called from user, kernel, or

interrupt context.

SEE ALSO

ddi_dma_alloc_handle(9F), ddi_dma_unbind_handle(9F)

Writing Device Drivers

SunOS 5.11 Last change: 26 Sep 1994 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™