Kernel Functions for Drivers ddi_dma_free(9F)
NAME
ddi_dma_free - release system DMA resources
SYNOPSIS
#include
#include
int ddi_dma_free(ddi_dma_handle_t handle);
INTERFACE LEVEL
This interface is obsolete. ddi_dma_free_handle(9F) should
be used instead.PARAMETERS
handle The handle filled in by a call toddi_dma_setup(9F).
DESCRIPTION
The ddi_dma_free() function releases system DMA resources
set up by ddi_dma_setup(9F). When a DMA transfer completes,
the driver should free up system DMA resources establishedby a call to ddi_dma_setup(9F). This is done by a call to
ddi_dma_free(). ddi_dma_free() does an implicit
ddi_dma_sync(9F) for you so any further synchronization
steps are not necessary.RETURN VALUES
The ddi_dma_free() function returns:
DDI_SUCCESS Successfully released resources
DDI_FAILURE Failed to free resources
CONTEXT
The ddi_dma_free() function can be called from user, inter-
rupt, or kernel context.ATTRIBUTES
See attributes(5) for a description of the following attri-
butes:SunOS 5.11 Last change: 16 Jan 2006 1
Kernel Functions for Drivers ddi_dma_free(9F)
____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Stability Level | Obsolete ||_____________________________|_____________________________|
SEE ALSO
attributes(5), ddi_dma_addr_setup(9F),
ddi_dma_buf_setup(9F), ddi_dma_free_handle(9F),
ddi_dma_htoc(9F), ddi_dma_sync(9F), ddi_dma_req(9S)
Writing Device DriversSunOS 5.11 Last change: 16 Jan 2006 2