Windows PowerShell command on Get-command ddi_dma_devalign
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_dma_devalign

Kernel Functions for Drivers ddi_dma_devalign(9F)

NAME

ddi_dma_devalign - find DMA mapping alignment and minimum

transfer size

SYNOPSIS

#include

#include

#include

int ddi_dma_devalign(ddi_dma_handle_t handle, uint_t *alignment,

uint_t *minxfr);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI). This interface is obsolete.

PARAMETERS

handle The DMAhandle filled in by a successful call to

ddi_dma_setup(9F).

alignment A pointer to an unsigned integer to be filled in with the minimum required alignment for DMA. The alignment is guaranteed to be a power of two. minxfr A pointer to an unsigned integer to be filled in with the minimum effective transfer size

(see ddi_iomin(9F), ddi_dma_lim_sparc(9S) and

ddi_dma_lim_x86(9S)). This also is guaranteed

to be a power of two.

DESCRIPTION

The ddi_dma_devalign() Function determines after a success-

ful DMA mapping (see ddi_dma_setup(9F)) the minimum required

data alignment and minimum DMA transfer size.

RETURN VALUES

The ddi_dma_devalign() function returns:

DDI_SUCCESS The alignment and minxfr values have been

filled.

DDI_FAILURE The handle was illegal.

SunOS 5.11 Last change: 04 Apr 2006 1

Kernel Functions for Drivers ddi_dma_devalign(9F)

CONTEXT

The ddi_dma_devalign() function can be called from user,

interrupt, or kernel context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Obsolete |

|_____________________________|_____________________________|

SEE ALSO

ddi_dma_setup(9F), ddi_iomin(9F), ddi_dma_lim_sparc(9S),

ddi_dma_lim_x86(9S), ddi_dma_req(9S)

Writing Device Drivers

SunOS 5.11 Last change: 04 Apr 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™