Windows PowerShell command on Get-command ddi_dma_curwin
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_dma_curwin

Kernel Functions for Drivers ddi_dma_curwin(9F)

NAME

ddi_dma_curwin - report current DMA window offset and size

SYNOPSIS

#include

#include

#include

int ddi_dma_curwin(ddi_dma_handle_t handle, off_t *offp, uint_t *lenp);

INTERFACE LEVEL

This interface is obsolete. ddi_dma_getwin(9F) should be

used instead.

PARAMETERS

handle The DMA handle filled in by a call to

ddi_dma_setup(9F).

offp A pointer to a value which will be filled in with the current offset from the beginning of the object that is mapped for DMA. lenp A pointer to a value which will be filled in with the size, in bytes, of the current window onto the object that is mapped for DMA.

DESCRIPTION

The ddi_dma_curwin() function reports the current DMA window

offset and size. If a DMA mapping allows partial mapping,

that is if the DDI_DMA_PARTIAL flag in the ddi_dma_req(9S)

structure is set, its current (effective) DMA window offset

and size can be obtained by a call to ddi_dma_curwin().

RETURN VALUES

The ddi_dma_curwin() function returns:

DDI_SUCCESS The current length and offset can be esta-

blished.

DDI_FAILURE Otherwise.

CONTEXT

The ddi_dma_curwin() function can be called from user,

interrupt, or kernel context.

SunOS 5.11 Last change: 16 Jan 2006 1

Kernel Functions for Drivers ddi_dma_curwin(9F)

ATTRIBUTES

See attributes(5) for a description of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Stability Level | Obsolete |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), ddi_dma_getwin(9F), ddi_dma_movwin(9F),

ddi_dma_setup(9F), ddi_dma_req(9S)

Writing Device Drivers

SunOS 5.11 Last change: 16 Jan 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™