Windows PowerShell command on Get-command ddi_dma_burstsizes
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_dma_burstsizes

Kernel Functions for Drivers ddi_dma_burstsizes(9F)

NAME

ddi_dma_burstsizes - find out the allowed burst sizes for a

DMA mapping

SYNOPSIS

#include

#include

#include

int ddi_dma_burstsizes(ddi_dma_handle_t handle);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

handle A DMA handle that was filled in by a successful

call to ddi_dma_setup(9F).

DESCRIPTION

ddi_dma_burstsizes() returns the allowed burst sizes for a

DMA mapping. This value is derived from the dlim_burstsizes

member of the ddi_dma_lim_sparc(9S) structure, but it shows

the allowable burstsizes after imposing on it the limita-

tions of other device layers in addition to device's own limitations.

RETURN VALUES

ddi_dma_burstsizes() returns a binary encoded value of the

allowable DMA burst sizes. See ddi_dma_lim_sparc(9S) for a

discussion of DMA burst sizes.

CONTEXT

This function can be called from user or interrupt context.

SEE ALSO

ddi_dma_devalign(9F), ddi_dma_setup(9F),

ddi_dma_lim_sparc(9S), ddi_dma_req(9S)

Writing Device Drivers

SunOS 5.11 Last change: 1 Feb 1994 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™