Windows PowerShell command on Get-command ddi_dma_addr_setup
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_dma_addr_setup

Kernel Functions for Drivers ddi_dma_addr_setup(9F)

NAME

ddi_dma_addr_setup - easier DMA setup for use with virtual

addresses

SYNOPSIS

#include

#include

int ddi_dma_addr_setup(dev_info_t *dip, struct as *as, caddr_t addr,

size_t len, uint_t flags, int (*waitfp) (caddr_t), caddr_t arg,

ddi_dma_lim_t * lim, ddi_dma_handle_t *handlep);

INTERFACE LEVEL

This interface is obsolete. ddi_dma_addr_bind_handle(9F)

should be used instead.

PARAMETERS

dip A pointer to the device's dev_info structure.

as A pointer to an address space structure. Should be set to NULL, which implies kernel address space. addr Virtual address of the memory object. len Length of the memory object in bytes.

flags Flags that would go into the ddi_dma_req struc-

ture (see ddi_dma_req(9S)).

waitfp The address of a function to call back later if

resources aren't available now. The special func-

tion addresses DDI_DMA_SLEEP and DDI_DMA_DONTWAIT

(see ddi_dma_req(9S)) are taken to mean, respec-

tively, wait until resources are available or,

do not wait at all and do not schedule a call-

back. arg Argument to be passed to a callback function, if such a function is specified.

lim A pointer to a DMA limits structure for this dev-

ice (see ddi_dma_lim_sparc(9S) or

ddi_dma_lim_x86(9S)). If this pointer is NULL, a

SunOS 5.11 Last change: 04 Apr 2006 1

Kernel Functions for Drivers ddi_dma_addr_setup(9F)

default set of DMA limits is assumed.

handlep Pointer to a DMA handle. See ddi_dma_setup(9F)

for a discussion of handle.

DESCRIPTION

The ddi_dma_addr_setup() function is an interface to

ddi_dma_setup(9F). It uses its arguments to construct an

appropriate ddi_dma_req structure and calls

ddi_dma_setup(9F) with it.

RETURN VALUES

See ddi_dma_setup(9F) for the possible return values for

this function.

CONTEXT

The ddi_dma_addr_setup() can be called from user, interrupt,

or kernel context, except when waitfp is set to

DDI_DMA_SLEEP, in which case it cannot be called from inter-

rupt context.

ATTRIBUTES

See attributes(5) for a description of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Stability Level | Obsolete |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), ddi_dma_buf_setup(9F), ddi_dma_free(9F),

ddi_dma_htoc(9F), ddi_dma_setup(9F), ddi_dma_sync(9F),

ddi_iopb_alloc(9F), ddi_dma_lim_sparc(9S),

ddi_dma_lim_x86(9S), ddi_dma_req(9S)

Writing Device Drivers

SunOS 5.11 Last change: 04 Apr 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™