Windows PowerShell command on Get-command ddi_dev_regsize
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_dev_regsize

Kernel Functions for Drivers ddi_dev_regsize(9F)

NAME

ddi_dev_regsize - return the size of a device's register

SYNOPSIS

#include

#include

#include

int ddi_dev_regsize(dev_info_t *dip, uint_t rnumber, off_t *resultp);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

dip A pointer to the device's dev_info structure.

rnumber The ordinal register number. Device registers are

associated with a dev_info and are enumerated in

arbitrary sets from 0 on up. The number of regis-

ters a device has can be determined from a call

to ddi_dev_nregs(9F).

resultp Pointer to an integer that holds the size, in bytes, of the described register (if it exists).

DESCRIPTION

The ddi_dev_regsize() function returns the size, in bytes,

of the device register specified by dip and rnumber. This is useful when, for example, one of the registers is a frame buffer with a varying size known only to its proms.

RETURN VALUES

The ddi_dev_regsize() function returns:

DDI_SUCCESS A successful return. The size, in bytes, of

the specified register, is set in resultp.

DDI_FAILURE An invalid (nonexistent) register number was

specified.

CONTEXT

The ddi_dev_regsize() function can be called from user,

interrupt, or kernel context.

SunOS 5.11 Last change: 16 Jan 2006 1

Kernel Functions for Drivers ddi_dev_regsize(9F)

SEE ALSO

ddi_dev_nintrs(9F), ddi_dev_nregs(9F)

Writing Device Drivers

SunOS 5.11 Last change: 16 Jan 2006 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™