Windows PowerShell command on Get-command ddi_copyin
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man ddi_copyin

Kernel Functions for Drivers ddi_copyin(9F)

NAME

ddi_copyin - copy data to a driver buffer

SYNOPSIS

#include

#include

#include

int ddi_copyin(const void *buf, void *driverbuf, size_t cn, int flags);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

buf Source address from which data is transferred. driverbuf Driver destination address to which data is transferred. cn Number of bytes transferred. flags Set of flag bits that provide address space information about buf.

DESCRIPTION

This routine is designed for use in driver ioctl(9E) rou-

tines for drivers that support layered ioctls. ddi_copyin()

copies data from a source address to a driver buffer. The

driver developer must ensure that adequate space is allo-

cated for the destination address. The flags argument determines the address space information about buf. If the FKIOCTL flag is set, this indicates that

buf is a kernel address, and ddi_copyin() behaves like

bcopy(9F). Otherwise, buf is interpreted as a user buffer

address, and ddi_copyin() behaves like copyin(9F).

Addresses that are word-aligned are moved most efficiently.

However, the driver developer is not obliged to ensure

alignment. This function automatically finds the most effi-

cient move according to address alignment.

SunOS 5.11 Last change: 19 Apr 2000 1

Kernel Functions for Drivers ddi_copyin(9F)

RETURN VALUES

ddi_copyin() returns 0, indicating a successful copy. It

returns -1 if one of the following occurs:

o Paging fault; the driver tried to access a page of memory for which it did not have read or write access. o Invalid user address, such as a user area or stack area. o Invalid address that would have resulted in data being copied into the user block. o Hardware fault; a hardware error prevented access to the specified user memory. For example, an uncorrectable parity or ECC error occurred.

If -1 is returned to the caller, driver entry point routines

should return EFAULT.

CONTEXT

ddi_copyin() can be called from user or kernel context only.

EXAMPLES

Example 1 ddi_copyin() example

A driver ioctl(9E) routine (line 12) can be used to get or

set device attributes or registers. For the XX_SETREGS con-

dition (line 25), the driver copies the user data in arg to the device registers. If the specified argument contains an invalid address, an error code is returned. 1 struct device { /* layout of physical device registers */ 2 int control; /* physical device control word */ 3 int status; /* physical device status word */

4 short recv_char; /* receive character from device */

5 short xmit_char /* transmit character to device */

6 };

7 struct device_state {

8 volatile struct device *regsp; /* pointer to device registers */

9 kmutex_t reg_mutex; /* protect device registers */

. . . 10 }; 11 static void *statep; /* for soft state routines */

12 xxioctl(dev_t dev, int cmd, int arg, int mode,

13 cred_t *cred_p, int *rval_p)

SunOS 5.11 Last change: 19 Apr 2000 2

Kernel Functions for Drivers ddi_copyin(9F)

14 {

15 struct device_state *sp;

16 volatile struct device *rp;

17 struct device reg_buf; /* temporary buffer for registers */

18 int instance; 19 instance = getminor(dev);

20 sp = ddi_get_soft_state(statep, instance);

21 if (sp == NULL) 22 return (ENXIO);

23 rp = sp->regsp;

. . . 24 switch (cmd) {

25 case XX_GETREGS: /* copy data to temp. regs. buf */

26 if (ddi_copyin(arg, ®_buf,

27 sizeof (struct device), mode) != 0) { 28 return (EFAULT); 29 }

30 mutex_enter(&sp->reg_mutex);

31 /* 32 * Copy data from temporary device register 33 * buffer to device registers.

34 * e.g. rp->control = reg_buf.control;

35 */

36 mutex_exit(&sp->reg_mutex);

37 break; 38 } 39 }

SEE ALSO

ioctl(9E), bcopy(9F), copyin(9F), copyout(9F),

ddi_copyout(9F), uiomove(9F)

Writing Device Drivers NOTES

The value of the flags argument to ddi_copyin() should be

passed through directly from the mode argument of ioctl() untranslated. Driver defined locks should not be held across calls to this function.

ddi_copyin() should not be used from a streams driver. See

M_COPYIN and M_COPYOUT in STREAMS Programming Guide.

SunOS 5.11 Last change: 19 Apr 2000 3




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™