Data Structures for Drivers datab(9S)
NAME
datab, dblk - STREAMS message data structure
SYNOPSIS
#include
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
DESCRIPTION
The datab structure describes the data of a STREAMS message.
The actual data contained in a STREAMS message is stored in a data buffer pointed to by this structure. A msgb (messageblock) structure includes a field that points to a datab
structure. Because a data block can have more than one message blockpointing to it at one time, the db_ref member keeps track of
a data block's references, preventing it from being deallo-
cated until all message blocks are finished with it. STRUCTURE MEMBERSunsigned char *db_base; /* first byte of buffer */
unsigned char *db_lim; /* last byte (+1) of buffer */
unsigned char db_ref; /* # of message pointers to this data */
unsigned char db_type; /* message type */
A datab structure is defined as type dblk_t.
SEE ALSO
free_rtn(9S), msgb(9S)
Writing Device Drivers STREAMS Programming GuideSunOS 5.11 Last change: 24 Oct 2003 1