Windows PowerShell command on Get-command csx_Parse_CISTPL_ORG
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man csx_Parse_CISTPL_ORG

Kernel Functions for Drivers csx_Parse_CISTPL_ORG(9F)

NAME

csx_Parse_CISTPL_ORG - parse the Data Organization tuple

SYNOPSIS

#include

int32_t csx_Parse_CISTPL_ORG(client_handle_t ch, tuple_t *tu,

cistpl_org_t *pt);

INTERFACE LEVEL

Solaris DDI Specific (Solaris DDI)

PARAMETERS

ch Client handle returned from csx_RegisterClient(9F).

tu Pointer to a tuple_t structure (see tuple(9S))

returned by a call to csx_GetFirstTuple(9F) or

csx_GetNextTuple(9F).

pt Pointer to a cistpl_org_t structure which contains the

parsed CISTPL_ORG tuple information upon return from

this function.

DESCRIPTION

This function parses the Data Organization tuple,

CISTPL_ORG, into a form usable by PC Card drivers.

The CISTPL_ORG tuple provides a text description of the

organization. STRUCTURE MEMBERS

The structure members of cistpl_org_t are:

uint32_t type;

char desc[CIS_MAX_TUPLE_DATA_LEN];

The fields are defined as follows: type This field indicates type of data organization.

SunOS 5.11 Last change: 24 Jan 1997 1

Kernel Functions for Drivers csx_Parse_CISTPL_ORG(9F)

desc[CIS_MAX_TUPLE_DATA_LEN]

This field provides the text description of this organi-

zation.

RETURN VALUES

CS_SUCCESS Successful operation.

CS_BAD_HANDLE Client handle is invalid.

CS_UNKNOWN_TUPLE Parser does not know how to parse

tuple.

CS_NO_CARD No PC Card in socket.

CS_NO_CIS No Card Information Structure

(CIS) on PC Card.

CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed.

CONTEXT

This function may be called from user or kernel context.

SEE ALSO

csx_GetFirstTuple(9F), csx_GetTupleData(9F),

csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S)

PC Card 95 Standard, PCMCIA/JEIDA

SunOS 5.11 Last change: 24 Jan 1997 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™