Kernel Functions for Drivers csx_Parse_CISTPL_DEVICEGEO(9F)
NAME
csx_Parse_CISTPL_DEVICEGEO - parse the Device Geo tuple
SYNOPSIS
#include
int32_t csx_Parse_CISTPL_DEVICEGEO(client_handle_t ch, tuple_t *tp,
cistpl_devicegeo_t *pt);
INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI)PARAMETERS
ch Client handle returned from csx_RegisterClient(9F).
tp Pointer to a tuple_t structure (see tuple(9S))
returned by a call to csx_GetFirstTuple(9F) or
csx_GetNextTuple(9F).
pt Pointer to a cistpl_devicegeo_t structure which con-
tains the parsed Device Geo tuple information upon return from this function.DESCRIPTION
This function parses the Device Geo tuple, CISTPL_DEVICEGEO,
into a form usable by PC Card drivers.The CISTPL_DEVICEGEO tuple describes the device geometry of
common memory partitions. STRUCTURE MEMBERSThe structure members of cistpl_devicegeo_t are:
uint32_t info[CISTPL_DEVICEGEO_MAX_PARTITIONS].bus;
uint32_t info[CISTPL_DEVICEGEO_MAX_PARTITIONS].ebs;
uint32_t info[CISTPL_DEVICEGEO_MAX_PARTITIONS].rbs;
uint32_t info[CISTPL_DEVICEGEO_MAX_PARTITIONS].wbs;
uint32_t info[CISTPL_DEVICEGEO_MAX_PARTITIONS].part;
uint32_t info[CISTPL_DEVICEGEO_MAX_PARTITIONS].hwil;
The fields are defined as follows:SunOS 5.11 Last change: 16 May 1997 1
Kernel Functions for Drivers csx_Parse_CISTPL_DEVICEGEO(9F)
info[CISTPL_DEVICEGEO_MAX_PARTITIONS].bus
This field indicates the card interface width in bytes for the given partition.info[CISTPL_DEVICEGEO_MAX_PARTITIONS].ebs
This field indicates the minimum erase block size for the given partition.info[CISTPL_DEVICEGEO_MAX_PARTITIONS].rbs
This field indicates the minimum read block size for the given partition.info[CISTPL_DEVICEGEO_MAX_PARTITIONS].wbs
This field indicates the minimum write block size for the given partition.info[CISTPL_DEVICEGEO_MAX_PARTITIONS].part
This field indicates the segment partition subdivisions for the given partition.info[CISTPL_DEVICEGEO_MAX_PARTITIONS].hwil
This field indicates the hardware interleaveRETURN VALUES
CS_SUCCESS Successful operation.
CS_BAD_HANDLE Client handle is invalid.
CS_UNKNOWN_TUPLE Parser does not know how to
parse tuple.CS_NO_CARD No PC Card in socket.
CS_NO_CIS No Card Information Structure
(CIS) on PC Card.SunOS 5.11 Last change: 16 May 1997 2
Kernel Functions for Drivers csx_Parse_CISTPL_DEVICEGEO(9F)
CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed.
CONTEXT
This function may be called from user or kernel context.SEE ALSO
csx_GetFirstTuple(9F), csx_GetNextTuple(9F),
csx_GetTupleData(9F), csx_Parse_CISTPL_DEVICEGEO_A(9F),
csx_RegisterClient(9F), tuple(9S)
PC Card 95 Standard, PCMCIA/JEIDA
SunOS 5.11 Last change: 16 May 1997 3