Windows PowerShell command on Get-command csx_GetEventMask
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man csx_GetEventMask

Kernel Functions for Drivers csx_SetEventMask(9F)

NAME

csx_SetEventMask, csx_GetEventMask - set or return the

client event mask for the client

SYNOPSIS

#include

int32_t csx_SetEventMask(client_handle_t ch, sockevent_t *se);

int32_t csx_GetEventMask(client_handle_t ch, sockevent_t *se);

INTERFACE LEVEL

Solaris DDI Specific (Solaris DDI)

PARAMETERS

ch Client handle returned from csx_RegisterClient(9F).

se Pointer to a sockevent_t structure

DESCRIPTION

The function csx_SetEventMask() sets the client or global

event mask for the client.

The function csx_GetEventMask() returns the client or global

event mask for the client.

csx_RequestSocketMask(9F) must be called before calling

csx_SetEventMask() for the client event mask for this

socket. STRUCTURE MEMBERS

The structure members of sockevent_t are:

uint32_t uint32_t /* attribute flags for call */

uint32_t EventMask; /* event mask to set or return */

uint32_t Socket; /* socket number if necessary */

The fields are defined as follows:

Attributes This is a bit-mapped field that identifies the

type of event mask to be returned. The field is defined as follows:

SunOS 5.11 Last change: 19 Jul 1996 1

Kernel Functions for Drivers csx_SetEventMask(9F)

CONF_EVENT_MASK_GLOBAL Client's global

event mask. If set, the client's global event mask is returned.

CONF_EVENT_MASK_CLIENT Client's local

event mask. If set, the client's local event mask is returned.

EventMask This field is bit-mapped. Card Services per-

forms event notification based on this field.

See csx_event_handler(9E) for valid event

definitions and for additional information about handling events. Socket Not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number.

RETURN VALUES

CS_SUCCESS Successful operation.

CS_BAD_HANDLE Client handle is invalid.

CS_BAD_SOCKET csx_RequestSocketMask(9F) not

called for

CONF_EVENT_MASK_CLIENT.

CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed.

CONTEXT

These functions may be called from user or kernel context.

SEE ALSO

csx_event_handler(9E), csx_RegisterClient(9F),

csx_ReleaseSocketMask(9F), csx_RequestSocketMask(9F)

PC Card 95 Standard, PCMCIA/JEIDA

SunOS 5.11 Last change: 19 Jul 1996 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™