Windows PowerShell command on Get-command csx_ConvertSpeed
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man csx_ConvertSpeed

Kernel Functions for Drivers csx_ConvertSpeed(9F)

NAME

csx_ConvertSpeed - convert device speeds

SYNOPSIS

#include

int32_t csx_ConvertSpeed(convert_speed_t *cs);

INTERFACE LEVEL

Solaris DDI Specific (Solaris DDI)

PARAMETERS

cs Pointer to a convert_speed_t structure.

DESCRIPTION

This function is a Solaris-specific extension that provides

a method for clients to convert from one type of device

speed representation to another, that is, from devspeed for-

mat to nS and vice versa. STRUCTURE MEMBERS

The structure members of convert_speed_t are:

uint32_t Attributes;

uint32_t nS;

uint32_t devspeed;

The fields are defined as follows:

Attributes This is a bit-mapped field that identifies

the type of speed conversion to be performed. The field is defined as follows:

CONVERT_NS_TO_DEVSPEED Converts nS to

devspeed format

CONVERT_DEVSPEED_TO_NS Converts devspeed

format to nS

nS If CONVERT_NS_TO_DEVSPEED is set, the value

in the nS field is converted to a devspeed format and returned in the devspeed field.

SunOS 5.11 Last change: 19 Jul 1996 1

Kernel Functions for Drivers csx_ConvertSpeed(9F)

devspeed If CONVERT_DEVSPEED_TO_NS is set, the value

in the devspeed field is converted to an nS value and returned in the nS field.

RETURN VALUES

CS_SUCCESS Successful operation.

CS_BAD_SPEED Invalid nS or devspeed.

CS_BAD_ATTRIBUTE Bad Attributes value.

CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed.

CONTEXT

This function may be called from user or kernel context.

SEE ALSO

csx_ModifyWindow(9F), csx_RequestWindow(9F)

PC Card 95 Standard, PCMCIA/JEIDA

SunOS 5.11 Last change: 19 Jul 1996 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™