Windows PowerShell command on Get-command clrbuf
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man clrbuf

Kernel Functions for Drivers clrbuf(9F)

NAME

clrbuf - erase the contents of a buffer

SYNOPSIS

#include

#include

void clrbuf(struct buf *bp);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

bp Pointer to the buf(9S) structure.

DESCRIPTION

The clrbuf() function zeros a buffer and sets the b_resid

member of the buf(9S) structure to 0. Zeros are placed in

the buffer starting at bp->b_un.b_addr for a length of

bp->b_bcount bytes. b_un.b_addr and b_bcount are members of

the buf(9S) data structure.

CONTEXT

The clrbuf() function can be called from user, interrupt, or

kernel context.

SEE ALSO

getrbuf(9F), buf(9S) Writing Device Drivers

SunOS 5.11 Last change: 16 Jan 2006 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™