Windows PowerShell command on Get-command bp_mapout
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man bp_mapout

Kernel Functions for Drivers bp_mapout(9F)

NAME

bp_mapout - deallocate virtual address space

SYNOPSIS

#include

#include

void bp_mapout(struct buf *bp);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

bp Pointer to the buffer header structure.

DESCRIPTION

bp_mapout() deallocates system virtual address space allo-

cated by a previous call to bp_mapin(9F).bp_mapout() should

only be called on buffers which have been allocated and are owned by the device driver. It must not be called on buffers passed to the driver through the strategy(9E) entry point

(for example a filesystem). Because bp_mapin(9F) does not

keep a reference count, bp_mapout() will wipe out any kernel

mapping that a layer above the device driver might rely on.

CONTEXT

bp_mapout() can be called from user context only.

SEE ALSO

strategy(9E), bp_mapin(9F), buf(9S)

Writing Device Drivers

SunOS 5.11 Last change: 15 Nov 1996 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™