Windows PowerShell command on Get-command bp_copyout
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man bp_copyout

Kernel Functions for Drivers bp_copyout(9F)

NAME

bp_copyout - copy from a driver buffer into a buf(9S)

SYNOPSIS

#include

#include

int bp_copyout(void *driverbuf, struct buf *bp, offset_t offset,

size_t size);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

bp Pointer to the buffer header structure to copy to. driverbuf Driver buffer to copy from. offset Offset into bp where to start copying. size Size of copy.

DESCRIPTION

The bp_copyout() function copies size bytes starting from

the driver buffer driverbuf to offset bytes into the memory associated with bp. The offset only applies to bp.

RETURN VALUES

Under normal conditions, 0 is returned to indicate a suc-

cessful copy. Otherwise, -1 is returned if bp references

invalid pages.

CONTEXT

The bp_copyout() function can be called from user or kernel

context only.

SEE ALSO

bp_copyin(9F), bp_mapin(9F), bp_mapout(9F), ddi_copyout(9F),

buf(9S)

SunOS 5.11 Last change: 16 Oct 2007 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™