Windows PowerShell command on Get-command bp_copyin
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man bp_copyin

Kernel Functions for Drivers bp_copyin(9F)

NAME

bp_copyin - copy from a buf(9S) into a driver buffer

SYNOPSIS

#include

#include

int bp_copyin(struct buf *bp, void *driverbuf, offset_t offset,

size_t size);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

bp Pointer to the buffer header structure to copy from. driverbuf Driver buffer to copy to. offset Offset into bp where to start copying. size Size of copy.

DESCRIPTION

The bp_copyin() function copies size bytes into the memory

associated with bp to the destination driver buffer driver-

buf. The offset only applies to bp.

RETURN VALUES

Under normal conditions, 0 is returned to indicate a suc-

cessful copy. Otherwise, -1 is returned if bp references

invalid pages.

CONTEXT

The bp_copyin() function can be called from user or kernel

context only.

SEE ALSO

bp_copyout(9F), bp_mapin(9F), bp_mapout(9F),

ddi_copyout(9F), buf(9S)

SunOS 5.11 Last change: 16 Oct 2007 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™