Windows PowerShell command on Get-command biowait
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man biowait

Kernel Functions for Drivers biowait(9F)

NAME

biowait - suspend processes pending completion of block I/O

SYNOPSIS

#include

#include

int biowait(struct buf *bp);

INTERFACE LEVEL

Architecture independent level 1 (DDI/DKI).

PARAMETERS

bp Pointer to the buf structure describing the transfer.

DESCRIPTION

Drivers allocating their own buf structures with

getrbuf(9F) can use the biowait() function to suspend the

current thread and wait for completion of the transfer. Drivers must call biodone(9F) when the transfer is complete

to notify the thread blocked by biowait(). biodone() is usu-

ally called in the interrupt routine.

RETURN VALUES

0 Upon success

non-zero Upon I/O failure. biowait() calls geterror(9F)

to retrieve the error number which it returns.

CONTEXT

biowait() can be called from user context only.

SEE ALSO

biodone(9F), geterror(9F), getrbuf(9F), buf(9S) Writing Device Drivers

SunOS 5.11 Last change: 11 Apr 1991 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™