Windows PowerShell command on Get-command biofini
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man biofini

Kernel Functions for Drivers biofini(9F)

NAME

biofini - uninitialize a buffer structure

SYNOPSIS

#include

#include

void biofini(struct buf *bp);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI).

PARAMETERS

bp Pointer to the buffer header structure.

DESCRIPTION

The biofini() function uninitializes a buf(9S) structure. If

a buffer structure has been allocated and initialized using

kmem_alloc(9F) and bioinit(9F) it needs to be uninitialized

using biofini() before calling kmem_free(9F). It is not

necessary to call biofini() before freeing a buffer struc-

ture using freerbuf(9F) because freerbuf() will call

biofini() directly.

CONTEXT

The biofini() function can be called from any context.

EXAMPLES

Example 1 Using biofini()

struct buf *bp = kmem_alloc(biosize(), KM_SLEEP);

bioinit(bp); /* use buffer */

biofini(bp);

kmem_free(bp, biosize());

SEE ALSO

bioinit(9F), bioreset(9F), biosize(9F), freerbuf(9F),

kmem_alloc(9F), kmem_free(9F), buf(9S)

Writing Device Drivers

SunOS 5.11 Last change: 20 Nov 1996 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™