Windows PowerShell command on Get-command audio_fini_ops
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man audio_fini_ops

Kernel Functions for Drivers audio_init_ops(9F)

NAME

audio_init_ops, audio_fini_ops - initialize DDI entry points

for an audio device driver

SYNOPSIS

#include

void audio_init_ops(struct dev_ops *devops, const char *name);

void audio_fini_ops(struct dev_ops *devops);

PARAMETERS

devops pointer to the dev_ops(9S) vector for the device

instance name name of the audio driver, which must be the same as the kernel module name. For example, "audiohd".

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI)

DESCRIPTION

The audio_init_ops() function initializes the device opera-

tions vector for an audio driver, setting a number of entry points to common implementation from the audio framework. It

must be executed during the _init(9E) function for the

driver.

The actual values supplied by audio_init_ops() are the

fields for devo_cb_ops and devo_getinfo.

Device drivers need to supply any other entry points, espe-

cially the attach(9E), detach(9E), and quiesce(9E) entry points.

The ddi_driver_name(9F) function cannot be used to determine

the device driver's name, as there is not necessarily a

dev_info_t to use during the _init(9E) entry point. A con-

stant string must be supplied by the driver.

The audio_fini_ops() function undoes the work of

audio_init_ops() and releases resources allocated by

audio_init_ops().

SunOS 5.11 Last change: 21 Apr 2010 1

Kernel Functions for Drivers audio_init_ops(9F)

CONTEXT

These functions may be called from the driver's _init(9E)

and _fini(9E) entry points only.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), attach(9E), detach(9E), _fini(9E), _init(9E),

quiesce(9E), ddi_driver_name(9F), dev_ops(9S)

Writing Device Drivers NOTES

Audio device driver names are limited to at most 12 charac-

ters.

The audio DDI is provided by the drv/audio module. Develop-

ers should supply "-dy -Ndrv/audio" on the final link com-

mand line to ensure that symbol dependencies can be satis-

fied when the driver is loaded.

SunOS 5.11 Last change: 21 Apr 2010 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™