Windows PowerShell command on Get-command audio_engine_sync
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man audio_engine_sync

Driver Entry Points audio_engine_sync(9E)

NAME

audio_engine_sync - synchronize DMA caches for an audio

engine

SYNOPSIS

#include

void prefix_sync(void *state, unsigned nframes)

PARAMETERS

state pointer to driver supplied soft state nframes integer value indicating the number of frames that have been either sent or received and need to be synchronized in the cache since the last

time audio_engine_sync() was called

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI)

DESCRIPTION

The audio_engine_sync() function is used as a hook to

request device drivers to perform DMA cache synchronization of the buffer.

Drivers should call ddi_dma_sync(9F) when this function is

called. The direction used for the operation can be deter-

mined by the driver. Engines performing playback must use

DDI_DMA_SYNC_FORDEV, and engines performing record must use

DDI_DMA_SYNC_FORKERNEL.

Drivers are responsible for maintaining a running index to keep track of the offset where cache synchronization is needed, but the framework indicates how many frames need to be synchronized in the nframes parameter. Many drivers elect to synchronize the entire buffer for simplicity. The index should be reset to 0 whenever

audio_engine_start(9E) is called.

CONTEXT

This function may be called from user or interrupt context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

SunOS 5.11 Last change: 16 Apr 2010 1

Driver Entry Points audio_engine_sync(9E)

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), audio(7D), audio_engine_start(9E),

ddi_dma_sync(9F), audio_engine_ops(9S)

SunOS 5.11 Last change: 16 Apr 2010 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™