Driver Entry Points audio_engine_start(9E)
NAME
audio_engine_start, audio_engine_stop - start or stop an
audio engineSYNOPSIS
#include
int prefix_start(void *state);
void prefix_stop(void *state);
PARAMETERS
state pointer to driver supplied soft stateINTERFACE LEVEL
Solaris DDI specific (Solaris DDI)DESCRIPTION
The audio_engine_start() function starts an audio engine
that has been initialized with audio_engine_open(9E). This
initiates actual playback or recording of audio. The data transfer must start at the first frame in the engine's buffer.The audio_engine_stop() function stops an audio engine that
was previously started with audio_engine_start() and resets
the frame index back to 0. The master frame counter for the engine is not reset.Once audio_engine_stop() returns, the engine must not per-
form any further data transfers to or from the audio buffer. Furthermore, actual play back or capture of audio associated with the engine shall have ceased.RETURN VALUES
The audio_engine_start() function returns 0 on success or an
error number on failure.CONTEXT
These functions may be called from user, kernel, or inter-
rupt context.ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:SunOS 5.11 Last change: 16 Apr 2010 1
Driver Entry Points audio_engine_start(9E)
____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Interface Stability | Committed ||_____________________________|_____________________________|
SEE ALSO
attributes(5), audio(7D), audio_engine_open(9E),
audio_engine_ops(9S)
SunOS 5.11 Last change: 16 Apr 2010 2