Windows PowerShell command on Get-command audio_engine_playahead
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man audio_engine_playahead

Driver Entry Points audio_engine_playahead(9E)

NAME

audio_engine_playahead - return the play-ahead sample count

for an audio engine

SYNOPSIS

#include

uint_t prefix_playahead(void *state);

PARAMETERS

state pointer to driver supplied soft state.

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI)

DESCRIPTION

The audio_engine_playahead() function returns a driver-

supplied hint indicating how many frames the framework should queue up to the device to avoid device underruns. This entry point is optional and NULL may be supplied, in

which case the framework will assume a default that is rea-

sonable for most devices.

This entry point is most appropriate for devices with incon-

sistent scheduling, such as emulated devices or devices backed by user programs. For these devices, this entry point allows the driver to supply a larger value than the normal default.

RETURN VALUES

The audio_engine_playahead() function returns the number of

frames the framework should queue for playback.

USAGE

This function is only called after the device is first opened; the dynamically changing values are not supported.

CONTEXT

This function may be called from user or interrupt context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

SunOS 5.11 Last change: 16 Apr 2010 1

Driver Entry Points audio_engine_playahead(9E)

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), audio(7D), audio_engine_ops(9S)

SunOS 5.11 Last change: 16 Apr 2010 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™