Windows PowerShell command on Get-command audio_engine_format
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man audio_engine_format

Driver Entry Points audio_engine_format(9E)

NAME

audio_engine_format - return the sample format for an audio

engine

SYNOPSIS

#include

int prefix_format(void *state);

PARAMETERS

state pointer to driver supplied soft state

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI)

DESCRIPTION

The audio_engine_format() function is called by the frame-

work to determine the format of the engine. The audio framework supports the following formats for audio engines:

AUDIO_FORMAT_S16_LE 16-bit signed little endian linear

PCM

AUDIO_FORMAT_S16_BE 16-bit signed big endian linear PCM

AUDIO_FORMAT_S24_LE 24-bit signed little endian linear

PCM

AUDIO_FORMAT_S24_BE 24-bit signed big endian linear PCM

AUDIO_FORMAT_S32_LE 32-bit signed little endian linear

PCM

AUDIO_FORMAT_S32_BE 32-bit signed big endian linear PCM

The 24-bit bit types above store each 24-bit sample in a

32-bit word.

SunOS 5.11 Last change: 16 Apr 2010 1

Driver Entry Points audio_engine_format(9E)

An audio engine may not change the format it uses while it is open.

RETURN VALUES

The audio_engine_format() function returns the audio format

of the engine.

CONTEXT

This function may be called from user or interrupt context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), audio(7D), audio_engine_ops(9S)

SunOS 5.11 Last change: 16 Apr 2010 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™