Windows PowerShell command on Get-command audio_engine_count
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man audio_engine_count

Driver Entry Points audio_engine_count(9E)

NAME

audio_engine_count - return the sample count for an audio

engine

SYNOPSIS

#include

uint64_t prefix_count(void *state);

PARAMETERS

state pointer to driver supplied soft state

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI)

DESCRIPTION

The audio_engine_count() function returns the frame count of

the engine, which is the number of frames transferred by the

engine since it was last opened with audio_engine_open(9E).

For recording, this frame count will be the total number of frames that the engine has written into the buffer. For playback, it will be the number of frames that the engine has read from the buffer. This value is monotonically increasing and does not wrap.

The audio_engine_open() function, however, will reset the

frame count to 0. The frame count for the engine is related to the offset of the data in the buffer. Both normally increase as the engine makes progress, but the engine index wraps when it reaches

the end of the buffer or when the device is stopped and res-

tarted with audio_engine_stop(9E) and

audio_engine_start(9E).

RETURN VALUES

The audio_engine_count() function returns the number of

frames transferred by the engine since audio_engine_open()

was called.

CONTEXT

This function may be called from user or interrupt context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

SunOS 5.11 Last change: 16 Apr 2010 1

Driver Entry Points audio_engine_count(9E)

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), audio(7D), audio_engine_open(9E),

audio_engine_start(9E), audio_engine_stop(9E),

audio_engine_ops(9S)

SunOS 5.11 Last change: 16 Apr 2010 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™