Windows PowerShell command on Get-command audio_engine_chinfo
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man audio_engine_chinfo

Driver Entry Points audio_engine_chinfo(9E)

NAME

audio_engine_chinfo - return channel layout information for

an audio engine

SYNOPSIS

#include

void prefix_chinfo(void *state, int chan, unsigned *offsetp,

unsigned *incrementp);

PARAMETERS

state pointer to driver supplied soft state chan a channel number offsetp pointer to an unsigned integer where the driver stores the offset of the channel within the first sample incrementp pointer to an unsigned integer where the driver stores the increment for the channel between samples

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI)

DESCRIPTION

The audio_engine_chinfo() function is used by the framework

to determine the layout of channel data within the audio stream. The offset indicates the index to the channel's sample data within an audio frame.

The increment is the number of samples separating the chan-

nel between adjacent frames. Both offset and increment are in units of the individual

sample size. For example, for signed 16-bit linear PCM, the

units are given as int16_t. This is true regardless of

whether the engine is monophonic, stereophonic, or in some other configuration.

SunOS 5.11 Last change: 16 Apr 2010 1

Driver Entry Points audio_engine_chinfo(9E)

For engines with typical interleaved samples, the offset value is the same as the channel number, and the increment

value is the number of channels for which the engine is con-

figured. If NULL is provided for this entry point, then this simple interleaved layout is assumed.

Other layouts can be used to reorder the channels (by chang-

ing the offset value) or interleave data from separate buffers together (by changing the increment value.) This can be used to achieve a functionality similar to the "remux" feature of other audio systems. This entry point is only supported for playback. An audio engine may not change the layout of its buffers while it is open

CONTEXT

This function may be called from user or kernel context.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), audio(7D), audio_engine_ops(9S)

SunOS 5.11 Last change: 16 Apr 2010 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™