Kernel Functions for Drivers audio_dev_set_description(9F)
NAME
audio_dev_set_description, audio_dev_set_version,
audio_dev_add_info - set human-readable information fields
for an audio deviceSYNOPSIS
#include
void audio_dev_set_description(audio_dev_t *adev, const char *desc);
void audio_dev_set_version(audio_dev_t *adev, const char *vers);
void audio_dev_add_info(audio_dev_t *adev, const char *info);
PARAMETERS
adev pointer to an audio device allocated withaudio_dev_alloc(9F)
desc a short description of the devicevers a human-readable version for the device
info additional human-readable details about the device
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI)DESCRIPTION
The audio_dev_set_description() and audio_dev_version()
functions set strings describing the device for applications to display this information to users.The audio_dev_add_info() function provides more detailed
information, such as codec details. Successive calls to this function are additive. Each addition will represent one line of output in any detailed device report. The strings are copied by the framework, so drivers may use local or temporary storage for them. They must be properly terminated with null bytes. Only the ASCII character set is supported.SunOS 5.11 Last change: 21 Apr 2010 1
Kernel Functions for Drivers audio_dev_set_description(9F)
The supplied strings may be truncated to 16 characters by some applications.CONTEXT
These functions may be called from user or kernel context only.ATTRIBUTES
See attributes(5) for descriptions of the following attri-
butes:____________________________________________________________
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|_____________________________|_____________________________|
| Interface Stability | Committed ||_____________________________|_____________________________|
SEE ALSO
attributes(5), audio(7D), audio_dev_alloc(9F)
SunOS 5.11 Last change: 21 Apr 2010 2