Windows PowerShell command on Get-command audio_dev_resume
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man audio_dev_resume

Kernel Functions for Drivers audio_dev_suspend(9F)

NAME

audio_dev_suspend, audio_dev_resume - suspend or resume an

audio device

SYNOPSIS

#include

void audio_dev_suspend(audio_dev_t *adev);

void audio_dev_resume(audio_dev_t *adev);

PARAMETERS

adev pointer to an audio device allocated with

audio_dev_alloc(9F)

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI)

DESCRIPTION

The audio_dev_suspend() function suspends all functions

associated with an audio device. The intention is for the audio driver to call this as the first part of its handling

for DDI_SUSPEND in detach(9E).

The audio_dev_resume() function resumes functionality asso-

ciated with the audio device. This function will generally be the last thing executed during the handling for

DDI_RESUME in attach(9E).

The framework ensures no entry points associated with the audio device are executing while the device is suspended. Furthermore, the framework guarantees that any engines that

may have been running are stopped with audio_engine_stop(9E)

before returning from audio_dev_suspend(). Those engines

will be restarted using audio_engine_start(9E) by

audio_dev_resume().

Any control settings are retrieved during suspend and restored as during resume. The driver must not hold any locks while calling either of these functions.

CONTEXT

SunOS 5.11 Last change: 21 Apr 2010 1

Kernel Functions for Drivers audio_dev_suspend(9F)

These functions may be called from user or kernel context only.

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), audio(7D), attach(9E),

audio_engine_start(9E), audio_engine_stop(9E), detach(9E),

audio_dev_add_control(9F), audio_dev_alloc(9F)

Writing Device Drivers

SunOS 5.11 Last change: 21 Apr 2010 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™