Windows PowerShell command on Get-command audio_dev_add_engine
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man audio_dev_add_engine

Kernel Functions for Drivers audio_dev_add_engine(9F)

NAME

audio_dev_add_engine, audio_dev_remove_engine - add or

remove an audio engine to or from a device

SYNOPSIS

#include

void audio_dev_add_engine(audio_dev_t *adev, audio_engine_t *engine);

void audio_dev_remove_engine(audio_dev_t *adev, audio_engine_t *engine);

PARAMETERS

adev pointer to an audio device allocated with

audio_dev_alloc(9F)

engine pointer to an audio engine allocated with

audio_engine_alloc(9F)

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI)

DESCRIPTION

The audio_dev_add_engine() function associates an allocated

and initialized engine with an audio device. Multiple engines may be added to an audio device in this fashion. Usually device drivers perform this at least twice: once for a playback engine and once for a record engine.

Multiple playback engines can be especially useful in allow-

ing the framework to avoid software mixing overhead or to

support engines running with different parameters. For exam-

ple, different engines may support different audio formats or different sample rates.

Generally, audio_dev_add_engine() should be called before

registering the audio device with the audio framework using

audio_dev_register(9F).

The audio_dev_remove_engine() function removes an engine

from the list of engines associated with a device. This is generally called during detach(9E) processing.

CONTEXT

These functions may be called from user or kernel context only.

SunOS 5.11 Last change: 21 Apr 2010 1

Kernel Functions for Drivers audio_dev_add_engine(9F)

ATTRIBUTES

See attributes(5) for descriptions of the following attri-

butes:

____________________________________________________________

| ATTRIBUTE TYPE | ATTRIBUTE VALUE |

|_____________________________|_____________________________|

| Interface Stability | Committed |

|_____________________________|_____________________________|

SEE ALSO

attributes(5), audio(7D), detach(9E), audio_dev_alloc(9F),

audio_dev_register(9F), audio_dev_unregister(9F),

audio_engine_alloc(9F)

SunOS 5.11 Last change: 21 Apr 2010 2




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™