Windows PowerShell command on Get-command allocb_tmpl
MyWebUniversity

Manual Pages for UNIX Operating System command usage for man allocb_tmpl

Kernel Functions for Drivers allocb_tmpl(9F)

NAME

allocb_tmpl - allocate a message block using a template

SYNOPSIS

#include

mblk_t *allocb_tmpl(size_t size, const mblk_t *tmpl);

INTERFACE LEVEL

Solaris DDI specific (Solaris DDI)

PARAMETERS

size The number of bytes in the message block. tmpl The template message block.

DESCRIPTION

The allocb_tmpl() function tries to allocate a STREAMS mes-

sage block using allocb(9F). If the allocation is success-

ful, the db_type field in the data block structure (dblk_t,

see datab(9S)), as well as some implementation-private data,

are copied from the dblk_t associated with tmpl.

The allocb_tmpl() function should be used when a new STREAMS

message block is allocated. This block is then used to con-

tain data derived from another STREAMS message block. The original message is used as the tmpl argument.

RETURN VALUES

Upon success, allocb_tmpl() returns a pointer to the allo-

cated message block of the same type as tmpl. On failure,

allocb_tmpl() returns a NULL pointer.

CONTEXT

The allocb_tmpl() function can be called from user, inter-

rupt, or kernel context.

SEE ALSO

allocb(9F), datab(9S), msgb(9S) Writing Device Drivers STREAMS Programming Guide

SunOS 5.11 Last change: 16 Jan 2006 1




Contact us      |      About us      |      Term of use      |       Copyright © 2000-2019 MyWebUniversity.com ™