Kernel Functions for Drivers IOC_CONVERT_FROM(9F)
NAME
IOC_CONVERT_FROM - determine if there is a need to translate
M_IOCTL contents.
SYNOPSIS
#include
uint_t IOC_CONVERT_FROM(struct iocblk *iocp);
INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI)PARAMETERS
iocp A pointer to the M_IOCTL control structure.
DESCRIPTION
The IOC_CONVERT_FROM macro is used to see if the contents of
the current M_IOCTL message had its origin in a different C
Language Type Model.RETURN VALUES
The IOC_CONVERT_FROM() function returns the following
values:IOC_ILP32 This is an LP64 kernel and the M_IOCTL ori-
ginated in an ILP32 user process.IOC_NONE The M_IOCTL message uses the same C Language
Type Model as this calling module or driver.CONTEXT
The IOC_CONVERT_FROM() macro can be called from user, inter-
rupt, or kernel context.SEE ALSO
ddi_model_convert_from(9F)
Writing Device Drivers STREAMS Programming GuideSunOS 5.11 Last change: 16 Jan 2006 1