Protocols icmp(7P)
NAME
icmp, ICMP - Internet Control Message Protocol
SYNOPSIS
#include
#include
#include
s = socket(AF_INET, SOCK_RAW, proto);
t = t_open("/dev/icmp", O_RDWR);
DESCRIPTION
ICMP is the error and control message protocol used by the
Internet protocol family. It is used by the kernel to handle and report errors in protocol processing. It may also beaccessed by programs using the socket interface or the Tran-
sport Level Interface (TLI) for network monitoring and diag-
nostic functions. When used with the socket interface, a"raw socket" type is used. The protocol number for ICMP,
used in the proto parameter to the socket call, can beobtained from getprotobyname(3SOCKET). ICMP file descriptors
and sockets are connectionless, and are normally used withthe t_sndudata / t_rcvudata and the sendto() / recvfrom()
calls. Outgoing packets automatically have an Internet Protocol (IP) header prepended to them. Incoming packets are provided to the user with the IP header and options intact.ICMP is an datagram protocol layered above IP. It is used
internally by the protcol code for various purposes includ-
ing routing, fault isolation, and congestion control.Receipt of an ICMP "redirect" message will add a new entry
in the routing table, or modify an existing one. ICMP mes-
sages are routinely sent by the protocol code. Received ICMP
messages may be reflected back to users of higher-level pro-
tocols such as TCP or UDP as error returns from systemcalls. A copy of all ICMP message received by the system is
provided to every holder of an open ICMP socket or TLI
descriptor.SEE ALSO
getprotobyname(3SOCKET), recv(3SOCKET), send(3SOCKET),t_rcvudata(3NSL), t_sndudata(3NSL), inet(7P), ip(7P),
routing(7P)Postel, Jon, Internet Control Message Protocol - DARPA
Internet Program Protocol Specification, RFC 792, Network Information Center, SRI International, Menlo Park, Calif.,SunOS 5.11 Last change: 3 Jul 1990 1
Protocols icmp(7P) September 1981. DIAGNOSTICS A socket operation may fail with one of the following errors returned:EISCONN An attempt was made to establish a connec-
tion on a socket which already has one, or when trying to send a datagram with the destination address specified and the socket is already connected. ENOTCONN An attempt was made to send a datagram, but no destination address is specified, and the socket has not been connected.ENOBUFS The system ran out of memory for an inter-
nal data structure. EADDRNOTAVAIL An attempt was made to create a socket with a network address for which no network interface exists. NOTESReplies to ICMP "echo" messages which are source routed are
not sent back using inverted source routes, but rather go back through the normal routing mechanisms.SunOS 5.11 Last change: 3 Jul 1990 2